Your browser does not support the canvas element.

Appliquettes bloquées par les paramètres de sécurité suite à la mise à jour de Java?

Suite à une mise à jour de Java la boîte de dialogue "application bloquée par les paramètres de sécurité" ci dessous risque d'apparaître en exécutant les appliquettes Java :

Applet non signée : une application non signée provenant de l'emplacement ci-dessous demande l'autorisation d'être exécutée. L'exécution de cette application peut présenter un risque de sécurité

Que faire?

  1. Vérifiez votre version de Java (elle doit être dorénavant supérieure ou égale à 1.7.0_55).
    Si nécessaire, mettez la à jour.
  2. Ajoutez l'URL http://duel-de-mots.com (voire http://www.duel-de-mots.com) à la liste des sites avec exception, qui se trouve sous l'onglet Sécurité du panneau de configuration Java
    (voir un exemple de vidéo d'explications sur youtube ou consulter plus de détails sur les sites de Java et de Firefox).
  3. (Si ça ne marche toujours pas,) il faut aussi activer Java dans votre navigateur.
    Pour le navigateur Firefox il faut activer le plug-in :
    1. A partir du menu Firefox, sélectionnez Outils, puis cliquez sur l'option Modules complémentaires.
    2. Dans l'onglet Gestionnaire de modules complémentaires, sélectionnez Plugins.
    3. Cliquez sur le plug-in Java (TM) Platform (Windows) ou Java Applet Plug-in (Mac OS X) pour le sélectionner.
    4. Vérifiez que l'option sélectionnée est Demander pour activer ou Toujours activer.
    Pour le navigateur Firefox il faut également toujours activer Java pour le site duel-de-mots (voire java.com).
  4. (Uniquement si ça ne marche toujours pas,) vérifiez si votre navigateur est en 32 ou 64 bits; attention vous devez télécharger la version 32 bits de Java si vous utilisez un navigateur 32 bits - plus de détails -.
Une fois l'URL http://duel-de-mots.com ajoutée à cette liste, mes appliquettes pourront être exécutées après la présentation de certains avertissements de sécurité.
Précision : mes appliquettes sont garanties sans virus et spyware; vous pouvez les exécuter sans crainte!

Ca ne marche pas?

Dysfonctionnement récent des appliquettes de Scrabble

  • Si une boîte de dialogue avec le message "Application bloquée par les paramètres de sécurité" s'affiche, vous devez suivre ces instructions pour débloquer les appliquettes.
  • Depuis novembre 2013 et la version 1.7.0_45-b18 de Java, il peut arriver que la première lettre déplacée ou cliquée disparaisse de la grille.
    Une solution pour contourner ce problème est de cliquer sur le bouton "<<" (pour revenir au premier coup de la partie). On peut alors rejouer la partie normalement!

Les "appliquettes" permettant de rejouer des parties interactives sélectionnées ou d'affronter un partenaire de Scrabble en "partie classique" se téléchargent toutes seules. La grille de jeu doit apparaitre dans une nouvelle fenêtre, qui ne contient pas de documentation, au bout d'un maximum de 3 minutes.
Si les "appliquettes" ne marchent pas chez vous, c'est probablement lié à la configuration (ou plus rarement à la version) de votre navigateur.

Que voyez-vous ci-dessous (à droite de la flèche)?

flèche à droite Message d'information : votre navigateur ne comprend pas Java ou vous en avez interdit l'utilisation!

  1. une zone rectangulaire vierge: votre navigateur comprend Java; soyez patient, cette zone devrait se remplir dans quelques secondes.
  2. une zone de texte sur fond rouge. Votre version de Navigateur n'est pas capable d'exécuter du code Java .
    Vous devriez installez un navigateur plus récent.
  3. une zone de texte sur fond vert. Et mes "appliquettes" ne marchent pas !?
    Il y a un autre problème que je ne connais pas. Merci de m'en dire un peu plus sur les symptômes.
  4. un message d'information explicite directement sur le fond de cette page! Essayez d'autoriser l'exécution de Java ou de mettre Java à jour.

Il se peut que Java ne soit pas installé sur votre ordinateur. Téléchargez le alors gratuitement sur le site officiel.

Si les instructions sur cette page se révèlent insuffisantes, vous pouvez obtenir plus d'informations sur les pages d'aide Java des sites de jeux Electronic Arts ou Arcade Village.

Informations complémentaires

Une description sommaire du problème pourrait me permettre de le résoudre. Merci de remplir le formulaire suivant.

L'idéal serait d'activer la "console Java" de votre navigateur :

  1. Netscape 4.5 à 4.7 : Communicateur->Outils->Console Java.
  2. Netscape 7 : Outils->Développement web->Console Java.
  3. Mozilla, Firefox : Automatique (rien à faire).
  4. Internet Explorer 5 et 6 : Affichage ->Console Java
    (Attention, cet item de menu n'apparait que si on l'a demandé dans Outils -> Options Internet -> Avancées -> Console Java Activée)

avant de relancer les "appliquettes", puis de me renvoyer les informations qui vont y apparaître lors de l'exécution d'une de ces appliquettes.

Votre mel : (pour obtenir une réponse)
Plateforme :
Navigateur : Version :
Description sommaire:
Output de la console Java:
 

Autoriser l'exécution de Java

  1. Netscape 4.5 à 7 : Edition->Préférences->Avancées-> Autoriser Java.
  2. Mozilla, Firefox : Outil->Options->Fonctionnalités web-> Activer Java.
  3. Opéra : Outils->Préférences->Advanced->Content -> Activer Java.
  4. Internet Explorer 5 et 6 : Outils -> Options Internet -> Sécurité
    cliquer sur le bouton "Personnaliser le niveau"
    rechercher la section Java et autoriser Java